Update Problem

  • I just went through the same problem and had already installed the same beta. You need to uninstall rc8 using control panel program and features. Then reinstall rc8. Then run the latest update and this should update and work fine.

    Custom built gaming desktop; Win10 pro, i9 9900k (water cooled) oc to 5ghz, zotac gtx 1080 ti blower, 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd. Asus ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, Oculus Rift cv1 w/2x sensors, and Asus VG248QE external 1080p 144hz gaming monitor. Now with new Vive Cosmos VR headset, looking good so far.

  • Thank you!

    But I had to do this silly procedure already for the last update!

    I do not believe that this is normal for to update a program.

    This is a bug in the update procedure, nothing else.

    Beside this I never installed intentionally a "beta", I install only the "officially" version.

  • Hallo Jürgen,


    falls Du Dir Kopien von den Versionen machst (ich mache das immer ;)), dann brauchst Du nur die Version V8.00.07.01 (also die vorletzte Version der Ikarus-Seite!) zu kopieren, dann funktioniert auch das neuste Update. Das geht schneller als eine Neuinstallation.


    Gruß

    Arthur

  • ja dann dieselbe tastenkombi einfach noch mal drücken?!

    Im Notfall kann man auch einfach im Aerofly RC 8 Ordner in deinem Dokumenteverzeichnis die base.mcf löschen oder manuell editieren und die einträge debug_show_log und debug_show_fps wieder auf false setzen. Normalerweise kann man diese debug infos aber ganz einfach mit ctrl+f1 oder ctrl+f2 ein und ausblenden.

  • Nach der manuellen Neuinstallation und diesem 17er Update bekomme ich irgendwelche Infos unten angezeigt. Kann mir bitte jemand sagen, wie ich diese wieder ausschalte?

    I think there is a small bug in the current 8.00.17.01 update. No pressing a few keys or editing the base config file will permanently fix this problem imho.


    If you have previously selected to show your FPS on your screen during your last flight and then exit RC8 when you startup again you will see those 2 lines at the bottom of the start screen. You will also see them on your screen when you start your flight. These do not effect performance. They just add unnecessary clutter to the bottom of your screen.


    The simple workaround I have found that works for me is to disable show FPS prior to going back to the main menu, then exit. When you startup again those lines will not be present in your statup screen, nor will they show up on your screen while flying. You can enable show FPS again while you are flying and those 2 lines will not show up, just your FPS, as per normal. You then just need to remember to disable show FPS before you stop your flight and before you go back to the main menu.


    For now I will just avoid showing FPS since I now have settings that work very well and it's one less thing to remember to do. I would only turn them on again if I wanted to change settings in order to see the effect of these changes.


    Otherwise, the latest public update seems to work pretty well (VR and non-VR). Since I had already got caught by the previous beta updates I knew enough to know I just needed to uninstall, reinstall, then update. Took me less than 5 minutes to do so no big deal imho. I'm still really enjoying RC8. Thanks Ikarus team!


    Edit; Sorry, I forgot to mention that this problem only happens in non-VR (flat screen). I does not appear at all in VR mode. So since +90% of my RC8 is flown VR it's not much an issue for me, lol!

    Custom built gaming desktop; Win10 pro, i9 9900k (water cooled) oc to 5ghz, zotac gtx 1080 ti blower, 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd. Asus ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, Oculus Rift cv1 w/2x sensors, and Asus VG248QE external 1080p 144hz gaming monitor. Now with new Vive Cosmos VR headset, looking good so far.

    Edited once, last by TomC RLG: Forgot to mention something. ().

  • ja dann dieselbe tastenkombi einfach noch mal drücken?!

    Im Notfall kann man auch einfach im Aerofly RC 8 Ordner in deinem Dokumenteverzeichnis die base.mcf löschen oder manuell editieren und die einträge debug_show_log und debug_show_fps wieder auf false setzen. Normalerweise kann man diese debug infos aber ganz einfach mit ctrl+f1 oder ctrl+f2 ein und ausblenden.

    Hi Jan,

    Danke, ich bin ja nicht blöd. Die Infos kommen und gehen nicht direkt bei Tastendruck, sondern tauchen erst beim nächsten Start auf. Wie soll ich da noch wissen, welche Taste ich gedrückt habe?!? Deine Tastenkombi geht bei mir auf jeden Fall nicht.

    Und das störende Zeugs erscheint erst seit ich alles komplett neu installieren musste (Jürgens eigentliches Problem hier) und noch keine Taste gedrückt hatte!! Da ist IMHO schon wieder ein Fehler drin!

  • Georgx, relax mate, it's just a minor bug. Please see my workaround on my post just before you latest 2 (post #14). No big deal and I'm sure this will get sorted out soon. Cheers, Tom

    Custom built gaming desktop; Win10 pro, i9 9900k (water cooled) oc to 5ghz, zotac gtx 1080 ti blower, 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd. Asus ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, Oculus Rift cv1 w/2x sensors, and Asus VG248QE external 1080p 144hz gaming monitor. Now with new Vive Cosmos VR headset, looking good so far.

  • It's not a bug, it's a feature for us developers. It might just be that the hot-keys to toggle these on or off are different.

    However my proposed solution of changing the base.mcf should still work.

    Only [debug_show_fps][false] did the trick. Thanks. But as soon as i switch the fps back on in the menu, the infos will show up after a restart of RC8 (as TomC described). Sorry, I do not know the developer hot-key strokes. Unfortunately all posted hot keys do not work for me (maybe delayed after a restart?).


    TomC, many thanks to your solution, but with the additional infos on the top, I couldn't see the menu and wasn't able to switch fps off. ;-)


    Jürgen, es tut mir leid, dass ich mich hier rein gedrängt habe. Ich dachte nur, das sollte zusammen mit Deinem Problem ausgemerzt werden. Ich wusste nicht, dass es so viel wird.