Object generation utility

  • un grand merci christophe,


    je viens de vérifier avec votre fichier modifié ... toujours rien ... nada ...


    Je vais incrémenter un autre objet, comme un simple pylône ligne haute-tension (j'ai couvert toute la Corse en 2 maps et sous PylonGen ... ils sont tous présents sur l'ensemble de la Corse).


    Peut-être l'objet est bugué ,

    Je vais aussi vérifier les coordonnées ... et s'il s'affichait ailleurs où je ne le vois pas ?


    une+ et encore merci.

    Cordialement.

    Michel.

    CPU Intel Core I7 6700 K @4.00 Ghz + BiQuiet Pure Rock - CM Asusteck MAXIMUS VIII RANGER - RAM GSkill Ripjaws4 DDR4 3000 16 GB - NVidia GeForce GTX 1060 3GB - 2x SSD Samsung 500 GB 850 EVO - DD WD 2 TO.

  • Suite pour christophe,


    j'ai une piste ... mais malheureusement sans réponse ...


    J'ai modifié l'appel à un objet situé dans un sous-répertoire, même hiérarchie de répertoires ... et lui s'affiche sans aucune autre modification !


    j'avais :

    <[string8][geometry][com_tower_models/100m_support_tower/100m_support_tower]> ... ne s'affiche pas !

    remplacé seulement par :

    <[string8][geometry][PowerPylonModels/4-cables/4-cables]> ... affichage ok !


    Détails des fichiers de l'objet qui ne s'affiche pas :

    sous-répertoire : com_tower_models

    contient :

    100m_support_tower

    125m_cell_towers

    200_500_red_and_white_radio_towers

    ... et 100m_support_tower contient les fichiers :

    100m_support_tower_metal_seamed.ttx

    100m_support_tower_metal_steel_textured__white.ttx

    100m_support_tower_metal_steel_textured__white_0.ttx

    100m_support_tower_obj.tmb

    100m_support_tower_reference.jpg


    Détails des fichiers de l'objet qui s'affiche :

    sous-répertoire : PowerPylonModels

    contient :

    3-cable-pole

    3-cables

    4-cables ... c'est le dossier appelé !

    + d'autres ...

    et donc, 4-cables appelé contient :

    4-cables.skp

    4-cables.tmb

    4-cables_4-cables_0.ttx

    4-cables_concrete_aggregate_smoke.ttx

    4-cables_metal_rough.ttx

    4-cables_quartz_light_brown.ttx


    tout cela semble identique (sauf erreur interne éventuelle dans un fichier) ...

    mais le dossier qui fonctionne ... comporte un fichier .skp important de 366 ko que le dossier qui fait erreur ne comporte pas !!! que penser ?


    Je pense que ce sont tous des fichiers d'objets 3D ceux qui ne fonctionnent pas proviendraient de SketchUp 2017.

    Ils ne sont pas non plus de même source !


    Avec votre fichier modifié, je vais essayer de changer d'objet et les essayer tous, je vous tiendrai au courant car cela peut être intéressant.


    Je faisais cet essai car j'ai en projet de couvrir de cette façon les réservoirs circulaires que ScenProc dernière mise à jour 7 ne produit pas malgré les lignes dédiées aux réservoirs.


    Si vous connaissez une source de fichiers sur les pylônes genre "Communication/TV/Internet", je suis intéressé. Les pylônes ligne haute-tension, j'ai toute une gamme fournie.


    Si vous êtes intéressé par la scène de Corse (ou je vie), j'ai images horto + couverture végétations et constructions + réseau pylônes haute-tension + les aéroports (mais en provenance de FsCloudPort ... pas génial !) ... la couverture "Cultivation" est très réussie (pas de moi). Le tout via Filemail qui accepte les très gros envois.


    a+ et encore merci à vous.


    Cordialement.

    Michel.

    CPU Intel Core I7 6700 K @4.00 Ghz + BiQuiet Pure Rock - CM Asusteck MAXIMUS VIII RANGER - RAM GSkill Ripjaws4 DDR4 3000 16 GB - NVidia GeForce GTX 1060 3GB - 2x SSD Samsung 500 GB 850 EVO - DD WD 2 TO.

  • Moin Michel,


    pouvez-vous envoyer le chemin complet du fichier que vous appelez avec <[string8][geometry][com_tower_models/100m_support_tower/100m_support_tower/100m_support_tower]> ?


    Parce qu'alors vous pouvez comparer 1:1 si tous les caractères sont vraiment identiques.


    Au revoir, Michael (III).

  • pour ApfelFlieger,


    je ne suis pas certain de comprendre ce que vous attendez par "chemin complet" sinon ... 1 clic droit sur le fichier puis "propriétés" ...


    que voici : G:\Steam\steamapps\common\Aerofly FS 2 Flight Simulator\scenery\places\fr\corse\corse_pylones\com_tower_models


    j'espère que c'est bien ce que vous attendez ...


    a+

    Michel

    CPU Intel Core I7 6700 K @4.00 Ghz + BiQuiet Pure Rock - CM Asusteck MAXIMUS VIII RANGER - RAM GSkill Ripjaws4 DDR4 3000 16 GB - NVidia GeForce GTX 1060 3GB - 2x SSD Samsung 500 GB 850 EVO - DD WD 2 TO.

  • Moin Michel,


    Désolé, je me suis exprimé un peu malheureux et j'ai essayé un peu plus en détail (bien que je vous demande par indulgence d'utiliser un programme de traduction) :


    Le fichier est appelé avec cette ligne de code :

    <[string8][geometry][com_tower_models/100m_support_tower/100m_support_tower]>


    Dans l'image dans l’article  #259 je ne vois malheureusement que le répertoire, dans lequel se trouve le fichier, mais pas le fichier.


    Parfois, ce n'est qu'une petite chose, ce qui n'est pas vrai. Et pour le savoir, je voulais voir le chemin exact du fichier:

    • com_tower_models/100m_support_tower/ ???


    Peut-être que c'est plus clair maintenant.



    Au revoir, Michael (III)

  • Tu pourrais le mettre sur fligh-sim.org avec le reste des sceneries generees par les utilisateurs.

    Ici (sur ce forum), ils ne vont pas te laisser mettre un lien sur tes fichiers directement, ou je je sais quoi, probleme legal. Sur flight-sim.org tu peux.

  • Bonsoir Michel,

    Comme Michael l’estime, la référence à l’objet ne semble pas être correcte.


    Le nom de l’objet est "100m_support_tower_obj". Ainsi, il manque probablement que le "_obj" à la fin:
    <[string8][geometry][com_tower_models/100m_support_tower/100m_support_tower
    _obj]>


    Les fichiers "* .skp", la il s’agit des fichiers originaux des modèles de SketschUp. Ils ne sont pas nécessaires ainsi que les images "*. jpg".

    Seul le fichier *. tmb" du modèle Aerofly FS2 avec les textures appropriées "*.ttx" sont nécessaires.

    J'ai fait la Corse il y a quelque temps, certainement pas si détaillé que le vôtre. De ce point de vue une comparaison serait intéressante.


    Regards,
    Christophe

  • un grand et énorme MERCI à vous deux ApfelFlieger et chrispriv ...


    vous avez tous les deux raison ... il fallait bien vérifier les chemins, libellés des fichiers ...etc ... car le problème était tout simple, mais "vicieux" !


    J'ai été dérouté parce-que le pylône s'affiche bien malgré qu'il n'y ai pas de fichier .obj dans son répertoire, seulement : 4-cables.tmb ...!


    Dans le répertoire de l'objet qui ne s'affiche pas; il y a bien un fichier "100m suppor tower_obj.tmb ... et avez-vous remarqué le"bug" ???


    support est mal orthographié en "100m suppor tower_obj.tmb ... et tout est OK comme quoi, il faut bien ajuster ses lunettes et rechercher la moindre erreur cachée ou non.


    Forcément, et maladroitement j'ai corrigé l'erreur sans même penser que cela est impossible.


    Une semaine entière à quasiment tout essayer, sans succès, mais vous m'avez tous les deux permis de trouver le défaut.


    Je vais pouvoir maintenant, avec cet essai positif, tenter d'ajouter les réservoirs ronds qu' ObjectGen ou ScenProc n'a pas placé malgré le script v.7 modifié qui a les lignes de traitement des réservoirs.


    Encore un grand merci et excellent dimanche à vous deux.


    Cordialement.

    M.Petit

    CPU Intel Core I7 6700 K @4.00 Ghz + BiQuiet Pure Rock - CM Asusteck MAXIMUS VIII RANGER - RAM GSkill Ripjaws4 DDR4 3000 16 GB - NVidia GeForce GTX 1060 3GB - 2x SSD Samsung 500 GB 850 EVO - DD WD 2 TO.

  • J'ai une autre question ...


    j'ai entré 5 objets de Pylones/TV et Com ... mais un seul s'affiche, le premier des 5.


    Qu'elle relation y a-t-il entre les coordonnées entrées en haut :

    <[vector2_float64][position][9.3994322 42.694407]>

    et celles des objets :

    <[vector3_float64][position][9.399836 42.694098 0]>

    <[vector3_float64][position][9.399435 42.694411 0]>

    <[vector3_float64][position][9.401355 42.695318 0]>

    <[vector3_float64][position][9.401355 42.695318 0]>

    <[vector3_float64][position][9.399975 42.696813 0]>


    question délicate il me semble.


    Merci pour votre aide


    Cordialement.

    a+

    Michel


    fichier .tsc ci-joint.

    Files

    CPU Intel Core I7 6700 K @4.00 Ghz + BiQuiet Pure Rock - CM Asusteck MAXIMUS VIII RANGER - RAM GSkill Ripjaws4 DDR4 3000 16 GB - NVidia GeForce GTX 1060 3GB - 2x SSD Samsung 500 GB 850 EVO - DD WD 2 TO.

    Edited once, last by dauphin20217 ().

  • Moin Michael,


    veuillez essayer ce code:

    Encore quelques indices :


    • Chaque "<" doit être fermé avec un ">".
    • Les commentaires doivent être précédés de "//".
    • En général, seules les lettres minuscules doivent être utilisées (je n'ai pas corrigé cela).
    • En général, aucun espace ne doit être utilisé (je n'ai pas corrigé cela).


    Bonne chance, Bye, Michael (III)

  • BINGO !!!


    4 magnifiques pylônes divers (ils devraient être 5 mais ... je m'en passe !)

    J'ai le nez sur l'écran et sur une copie imprimée chercher où se cache le problème ... rien n'est vraiment évident ...


    -1- les numéros d'éléments, j'avais un affichage avec [0] à [4] et sans [0] ...

    -2- les # ... j'ai confondu avec les commentaires sur les scripts ... peut-être grosse perturbation !

    -3- les signes < et > oui, il m'en manquait plusieurs !

    -4- les (espaces) et Majuscules/minuscules ... j'ai respecté scrupuleusement les noms de dossiers et fichiers sans RIEN y changé, expérience précédente !

    et affichage ok, mais je sais qu'IPACS recommande de proscrire les Majuscules (et les espaces comme habituellement).


    en fait, un tout petit détail qui plante l'affichage donc : un ENORME MERCI, j'ai appris quelque chose de plus et c'est l'essentiel.


    Je garde précieusement ce fichier comme MODÈLE, il me servira pour implanter quelques réservoirs qui manquent proches d'aéroports.

    La création manuellement de fichiers .tsc est souvent plus gratifiante que de passer par des logiciels plus ou moins bien documentés ! Pas de merci à IPACS.


    Je suis très satisfait et en joie de pouvoir poursuivre.


    Capture photo sur le site, dommage que le sol est flouté (zone sensible) idem sous Google, Bing, IGN ... je n'avais pas remarqué sinon des "copier/coller" avec tampon auraient été plus propre.


    A nouveau, UN GRAND MERCI à vous.


    Cordialement.

    a+

    Michel.



    CPU Intel Core I7 6700 K @4.00 Ghz + BiQuiet Pure Rock - CM Asusteck MAXIMUS VIII RANGER - RAM GSkill Ripjaws4 DDR4 3000 16 GB - NVidia GeForce GTX 1060 3GB - 2x SSD Samsung 500 GB 850 EVO - DD WD 2 TO.

  • nouveau petit problème ... si vous pouviez m'aider ... ApfelFlieger et chrispriv ...


    j'ai facilement créé un réservoir en modifiant mon .tsc d'objets pylônes et ... il s'affiche de suite, génial !


    mais, il vient en superposition sur des bâtiments issus de la cultivation générale ... impossible d'ouvrir le fichier avec l'excellent AFS2 Scenery Editor

    car il est compilé !, j'aurais pu les supprimer facilement.


    Donc, je voudrait ajouter en en-tête de mon fichier .tsc une zone d'exclusion. Cela pourrait fonctionner mais impossible de retrouver sur les différents forums le code à ajouter.


    Joint mon .tsc (en .txt) et image du résultat provisoire, toutes les constructions devraient être des citernes (en fait, plutôt des bassins d'épuration, mais je n'ai pas encore les objets ).


    Je continue à chercher mais je suis séché ! Merci pour votre aide.


    Cordialement.

    Michel.

  • Honnêtement, je suis un peu hors de ma catégorie en ce moment. Je connais le problème de certains aéroports. Le problème a été résolu en recréant la culture environnante et en excluant l'aérodrome afin qu'aucun bâtiment gênant ne soit créé.


    Je ne sais pas s'il est possible de cacher l'affichage des éléments d'un autre fichier dans un fichier.


    Tschüss, Michael.

  • Merci quand même Michael.


    Dans mon cas, je suis hors de la zone d'un aéroport. Je recherche s'il est possible de décompiler le fichier de cultivation générale ensemble de la Corse. Ensuite AFS2 Scenery Editor peut très bien supprimer des objets bâtiments et cultivation ... mais il faudrait le recompiler !.


    Tschüss, Michel.

    CPU Intel Core I7 6700 K @4.00 Ghz + BiQuiet Pure Rock - CM Asusteck MAXIMUS VIII RANGER - RAM GSkill Ripjaws4 DDR4 3000 16 GB - NVidia GeForce GTX 1060 3GB - 2x SSD Samsung 500 GB 850 EVO - DD WD 2 TO.

  • à Antoine please ...


    Je suis hors de la zone d'un aéroport. Je recherche s'il est possible de décompiler le fichier de cultivation générale ensemble de la Corse. Ensuite AFS2 Scenery Editor peut très bien supprimer des objets bâtiments et cultivation ... mais il faudrait le recompiler !.


    Je souhaite ajouter des citernes à un emplacement ou la cultivation a déjà créé des constructions.


    Peut-être simplement ajouter en en-tête de mon .tsc une zone d'exclusion mais je ne sais pas comment l'écrire.


    SVP ! merci à vous.


    Michel.

    CPU Intel Core I7 6700 K @4.00 Ghz + BiQuiet Pure Rock - CM Asusteck MAXIMUS VIII RANGER - RAM GSkill Ripjaws4 DDR4 3000 16 GB - NVidia GeForce GTX 1060 3GB - 2x SSD Samsung 500 GB 850 EVO - DD WD 2 TO.

  • Merci quand même Michael.


    Dans mon cas, je suis hors de la zone d'un aéroport. Je recherche s'il est possible de décompiler le fichier de cultivation générale ensemble de la Corse. Ensuite AFS2 Scenery Editor peut très bien supprimer des objets bâtiments et cultivation ... mais il faudrait le recompiler !.

    Bonsoir Michel,


    Selon ma connaissance, contrairement à la default-végétation de IPAC, il n’existe effectivement aucun moyen d’exclure une zone ou de décomprimer une cultivation comprimée.

    Vous devez effectivement demander à l'auteur de le faire ou d'obtenir la version non comprimée.


    Christophe

  • Merci Christophe,


    dommage de ne pouvoir supprimer les constructions parasites ... mais je viens de vérifier et les cultivations des scènes IPACS sont aussi compilées et donc inaccessibles. Seules le seraient celles créés par nous-même et non compilées, cela afin je suppose de réduire leurs tailles en Mo mais aucune aide pour nous les utilisateurs !


    J'ai augmenté la taille des citernes afin de couvrir mieux les bâtiments mais ils restent visibles !


    j'attends une éventuelle solution, ce serait intéressant de trouver un moyen de nettoyer la zone (mais je regarde l'opportunité de me procurer l'original non compilé, ce serait alors possible).


    Merci à vous.

    a+

    Michel.