AH64A Apache version 1.0

  • Hi All


    Just posted the release version of the Apache, can really take it much further at the moment, still need to work on nav stuff which I plan to do now, If I work it out I will add it to the Lynx.


    Also included a manual, Cold and dark for the geeks, plus the paintkits


    https://flight-sim.org/filebas…/1057-ah64a-version-1-00/


    https://flight-sim.org/filebas…?entry/1058-ah64a-manual/


    https://flight-sim.org/filebas…1059-paintkits-for-ah64a/


    Time for a rest, think I've earned it:rolleyes:


    Steve

  • Great job and THANKS A LOT Steve for this wonderful achievement! :thumbup:


    Only small regret for the Lynx, it would also have been good to have the 2 modes, either Auto or Cold and dark


    so that novices and lazy like me can enjoy it without having to read.=O;(


    Have a good rest and take care of all of you.:sleeping:;)

    Cheers,

    Pascal


    Intel I7-4930MX - 3,90 GHz - 32 Go - GTX 880M - 8 Go - Samsung SSD M.2 250 Go + Samsung SSD M.2 750 Go - Win10 Pro

  • Totally agree it's a detailed masterpiece. The only other things missing are kinetic systems but this demonstrates the massive complexity without considering firepower. It also frees the mind to concentrate on flight and that's a lot.


    I also agree - an auto step by step cold & dark startup especially for VR - that would take it to another level.


    😎👍🏼👍🏼

  • Hi I have just installed on my mac FS 2 (non steam) in the add-on airplane directory. I can select a flavour of the Apache. It even tells me loading apache helicopter but when it starts I have a cessna plane :-(... Any idea what goes wrong? I have used the latest 1,0 version

  • Sorry unable to help as I do not have a Mac, perhaps Jetpack or other Mac users will offer some advice. Please ensure you downloaded the Release version as the WIP versions didn't have the options files and it's normally the lack of these that causes this error.


    Steve

  • Hi I have just installed on my mac FS 2 (non steam) in the add-on airplane directory. I can select a flavour of the Apache. It even tells me loading apache helicopter but when it starts I have a cessna plane :-(... Any idea what goes wrong? I have used the latest 1,0 version

    Thank you for this information.


    Can you please show the lines with the error messages for the airfields from the tm.log? Maybe I can adjust something for the airports where I am involved.

    Tschüss, Michael (🍎🚁)


    Configuration: MacBookPro 15-inch, 2018; Pocessor: 2,9 GHz 6-Core Intel Core i9; RAM: 32 GB 2400 MHz DDR4; Graphics board: Intel UHD Graphics 630 1536 MB)

  • Here are my results:


    I save the additional planes in this directory on the MacBook Pro:

    - /Users/username/Library/Containers/com.aerofly.aerofly-fs-2-mac/Data/Library/Application Support/Aerofly FS 2/aircraft

    - Note: this is not the "addon“ directory:

    /Users/username/Library/Containers/com.aerofly.aerofly-fs-2-mac/Data/Library/Application Support/Aerofly FS 2/addons/aircraft


    The AH64A Apache version 1.00 only works for me with the STEAM version of Aerofly FS2.:)


    With the Apple version of Aerofly FS2 I unfortunately only see the red cube STOP.:(


    However, in the Apple version of Aerofly FS2, the first version of AH64A Apache works for me from 2020-07-20 (https://flight-sim.org/filebas…php?entry/1004-ah64a-wip/)


    Unfortunately, I do not know at the moment what the reason could be that as of update 2 I only see the red cube STOP. It should only be a small adjustment.:/

    Tschüss, Michael (🍎🚁)


    Configuration: MacBookPro 15-inch, 2018; Pocessor: 2,9 GHz 6-Core Intel Core i9; RAM: 32 GB 2400 MHz DDR4; Graphics board: Intel UHD Graphics 630 1536 MB)

  • On the PC version we have a TM.log in the C:\Users\XXX\Documents\Aerofly FS 2. Does this file also exist on the mac. if so can you post it.


    This file will normally explain why the dreaded red cube has appeared


    Also, many thanks for all the messages, really appreciated :thumbup:


    Steve

  • Oops, I could have thought of that myself:X(


    Files

    • tm.log.txt

      (63.13 kB, downloaded 25 times, last: )

    Tschüss, Michael (🍎🚁)


    Configuration: MacBookPro 15-inch, 2018; Pocessor: 2,9 GHz 6-Core Intel Core i9; RAM: 32 GB 2400 MHz DDR4; Graphics board: Intel UHD Graphics 630 1536 MB)

  • HI Michael


    It would seem the MAC is less tolerant than the PC as it runs with no errors on the PC.


    I looked at the errors in your file and I have hopefully corrected them. Perhaps the 4 "NAV1Frequency.Set" may still cause me problems. They relate to the TACAN, which works perfectly on the PC.


    I will PM the updated file as I don't want to include a updated TMQ file on the forum until I know its working fine. Once all is Ok I will post it over on the Flight-sim.org site so everyone can update.


    Steve

  • Hi Michael


    Thanks for the updated log file. The new file did find yet another minor error which I have corrected. Quite why it didn't find this error the first time is past my pay grade.


    We do still have the NAV1Frequency errors but I can't see why that should be so I will consult with Master Obi Jan next week. He's on a well earned break so I'll leave him in peace.


    Happy New Year to you and all the other forum members


    Steve

  • Please find attached the latest data from my TM.log during the Apache loading procedure.


    28.72-tmsimulator: loading model 'apache': name='apache' folder='/Users/stefanvandemaele/Library/Containers/com.aerofly.aerofly-fs-2-mac/Data/Library/Application Support/Aerofly FS 2/addons/aircraft/apache/'\

    28.72-tmmodelmanager: model: (name='apache') (directory='/Users/stefanvandemaele/Library/Containers/com.aerofly.aerofly-fs-2-mac/Data/Library/Application Support/Aerofly FS 2/addons/aircraft/apache/')\

    28.72-tmmodelmanager: loading configfile '/Users/stefanvandemaele/Library/Containers/com.aerofly.aerofly-fs-2-mac/Data/Library/Application Support/Aerofly FS 2/addons/aircraft/apache/apache.tmc'\

    28.73-tmmodelmanager: contact points 3: (-9.748 -0.000 -2.203 r=0.165) (1.126 1.031 -2.051 r=0.320) (1.126 -1.031 -2.051 r=0.320)\

    28.74-tmmodelmanager: option folders 1: (/Users/stefanvandemaele/Library/Containers/com.aerofly.aerofly-fs-2-mac/Data/Library/Application Support/Aerofly FS 2/addons/aircraft/apache/)\

    28.75-tmmodelmanager: filename apache.tmb\

    29.72-tmmodelmanager: loading dynamics begin 'apache'...\

    29.74-tmmodelmanager: ERROR: property 'GPSNavigationSystem.OutputNextWaypointElevation' not found\

    29.74-tmmodelmanager: ERROR: property 'NAV1Frequency.Set' not found\

    29.75-tmmodelmanager: ERROR: property 'NAV1Frequency.Set' not found\

    29.75-tmmodelmanager: ERROR: property 'NAV1Frequency.Set' not found\

    29.75-tmmodelmanager: ERROR: property 'NAV1Frequency.Set' not found\

    29.76-tmmodelmanager: ERROR: property 'LightingPilotFlood.Output.Output' not found\

    29.77-tmmodelmanager: ERROR: property 'LightingPilotFlood.Output.Output' not found\

    29.77-tmmodelmanager: ERROR: object 'HSIDistanceStrength' not found\

    29.77-tmmodelmanager: ERROR: property 'HSIDistanceStrength.Output' not found\

    29.79-tmmodelmanager: ERROR: object 'APUN1' not found\

    29.79-tmmodelmanager: ERROR: property 'APUN1.Output' not found\

    29.79-tmmodelmanager: ERROR: object 'CoPilotDoorPosition' not found\

    29.80-tmmodelmanager: ERROR: property 'CoPilotDoorPosition.Output' not found\

    29.81-tmmodelmanager: ERROR: error loading tmd file 'apache'.\

    29.88-tmmodelmanager: model: (name='c172') (directory='aircraft/c172/')\

    29.88-tmmodelmanager: loading configfile 'aircraft/c172/c172.tmc'\

    29.89-tmmodelmanager: contact points 3: (0.240 1.268 -0.923 r=0.212) (0.240 -1.268 -0.923 r=0.212) (1.924 0.000 -1.079 r=0.193)\

    29.90-tmmodelmanager: option folders 1: (aircraft/c172/)\

    29.91-tmmodelmanager: filename c172.tmb\

    30.89-tmmodelmanager: loading dynamics begin 'c172'...\

    31.17-tmmodelmanager: loading dynamics end: (id=1) (692 dynamics) (738 graphics) (172 sound) (ny=761) (nz=220)\

    31.17-tmmodelmanager: \

    31.17-tmmodelmanager: mass: 985.0 ( 0.682 0.000 0.151 )\

    31.17-tmmodelmanager: 1 multibody joints / 1 components\

    31.34-tmrigidbodygraphics: creating threaded tmpaint instance for 'DisplayTexture' and texture 'display_light'\

    31.35-tmrenderer_font: loading font 'texture/fontdisplay.tff'=(512x472) (h=45) (nc=25992) ok\

    31.36-tmrenderer_font: loading font 'texture/hud.tff'=(512x196) (h=48) (nc=123) ok\

    31.36-tmrenderer_font: loading font 'texture/fonthelp.tff'=(512x415) (h=57) (nc=188) ok\

    31.37-tmrenderer_font: loading font 'texture/segment.tff'=(512x196) (h=48) (nc=124) ok\

    31.44-tmrigidbodygraphics: creating threaded tmpaint instance for 'LcdTexture' and texture 'lcd_color'\

    31.45-tmrenderer_font: loading font 'texture/fontdisplay.tff'=(512x472) (h=45) (nc=25992) ok\

    31.45-tmrenderer_font: loading font 'texture/hud.tff'=(512x196) (h=48) (nc=123) ok\

    31.46-tmrenderer_font: loading font 'texture/fonthelp.tff'=(512x415) (h=57) (nc=188) ok\

    31.47-tmrenderer_font: loading font 'texture/segment.tff'=(512x196) (h=48) (nc=124) ok\

    31.53-tmsimulator: done loading model c172 (repaint=)\

    31.53-tmsimulator: \

    31.53-tmfile_properties: ERROR: (tm2file::LoadFile failed. error loading file '/Users/stefanvandemaele/Library/Containers/com.aerofly.aerofly-fs-2-mac/Data/Library/Application Support/Aerofly FS 2/addons/aircraft/apache/copilot.tmc')\

    31.54-tmterrain: creating terrain landmark class begin\

    31.54-tmrenderer_font: loading font 'texture/landmarks.tff'=(512x512) (h=45) (nc=8365) ok\

    }

  • This would appear to be a MAC problem as the PC version works fine even with these errors. I have corrected most of the errors (plus another one) as seen in your TM.log


    I am stuck on the NAV1Frequency.Set error. I plan to ask Jetpac for help but he is on a well earned vacation at the moment so it will have to wait.


    Once I have corrected this error I will post a new TMQ file.


    Steve