All of you public beta testers out there - POST YOUR BUGS HERE

  • A that issue, yeah yeah that's been there in the last version, no worries, I have it on the radar. Nothing I can do about it though, I'm afraid. The route is selecting the next leg a bit prematurely. I'll keep bugging the responsible programmer :D

    Good to know it's on the radar! ;) I myself can live with it: my passengers sometimes start to moan though. 8)

  • Finally I could try out the beta. I have an older gamer laptop (i7-4710HQ@2.5GHz, GTX860m 4GB, with 16GB DDR3 RAM and win10), so this is a 'slow' PC. :)

    The performance increase with the Vulkan driver is more than noticeable, with the standard installation (no extra scenery) it can handle High detail pretty well,
    using Vsync. Apparently the CPU is no longer throttling. I was unable to quote values because MSI Afterburner couldn't handle Vulkan, turning on the OSD rendered the whole screen blank. So I went without it. The OSD still shows twice the real frame rate both in Vulkan and in OpenGL (and OpenGL still shows 'D3D10' in MSI afterburner :/). Interestingly, this version runs much better in OpenGL too (compared to the last release).

    However, the Vulkan version crashes pretty often, I've attached the log. Most crashes occur when looking around and when zooming in/out in the cockpit.

    Nice work anyway, hopefully those bugs will be ironed out in no time! :thumbup:

    (Ps. Is there cold&dark for big birds (737/A320) coming ? :|)


    Best Regards


    Ryzen 2700X, HyperX 32GB, 2060 Super 8GB, win10/ubuntu19

    Saitek X52 HOTAS, Logitech G920 pedals

    X-Plane 11, DCS modules: A-10C, Ka-50, FC3, Mirage 2000C, F/A-18C, Persian Gulf

  • Switched to Vulkan while in VR. Control panel went black (blue surround). Went back in flew in 2D with Vulkan enabled OK. Then tried to go into VR again with Vulkan and could fly but was black when returning to control panel though I could go back and forth between flying and blacked out control panel.

  • The patch fixing transparent custom-made airports seems not to fix it yet : many users report transparent apron at my LSGY, while it works nice on "official" current release (i.e. non beta).

    Here's a snapshot showing that all material #2 ground surfaces are invisible and one sees the extruded mesh below (patch installed).

    [Blocked Image:]




    Config : i7 6900K - 20MB currently set at 3.20GHz, Cooling Noctua NH-U14S, Motherboard ASUS Rampage V Extreme U3.1, RAM HyperX Savage Black Edition 16GB DDR4 3000 MHz, Graphic Card Gigabyte GeForce GTX 1080 8GB, Power supply Corsair RM Series 850W, Windows 10 64 bit.

  • Hey boys

    I tried the beta last night and here's couple of things I would like to mention.

    Played in VR (Rift)

    Sun Effect

    the flare around the sun seems to "react" with left eye only. When there is an obstacle (like window frame) between view point and the sun, the flare around the sun disappears as soon as the left eye gets behind the obstacle regardless the fact that the right eye is still looking directly to the sun.

    It also rotates as you tilt your head which is very unnatural.

    Mouse cursor

    when moving the cursor around the cockpit, I noticed that I couldn't really focus on it as a single point. Somehow the stereo effect of the cursor isn't aligned properly. mostly noticeable when close to my face (<0.5m).

    Grab points

    I only flew 737 so far, don't know if this affect the other aircraft too but the grab points for mouse control seems to be misaligned. Maybe it has something to do with the issue above.

    Not all bad though

    I love the new features, great job gang! Most of all the rotary encoder input for AP is working again 8|^^ Yey.

    Talking about AP, I also wanna suggest a fix for hardware trim wheel. This was always an issue no matter what flight sim.

    When you have hardware trim wheel (e.g. saitek) assigned to the trim axes and engage the autopilot, fluctuations of the wheel's axis is constantly sending input data, colliding with the AP's attempts to balance the aircraft.

    The virtual trim wheel is then just oscillating on the spot as a result.

    Could you perhaps disable the hardware axis while the AP is engaged?

    Once more, great job guys.

    Very much looking forward to your first chopper:love:

    Over and Out


  • 737: Which "grab points" are misaligned in particular? Cause there are easily over 500 of them...

    Trim wheel: Saitek should have made the trim wheel incremental and not absolute... causes so many troubles... Now we have to spend even more time with that, just to fix analog axes for the trim... We'll take a look, see what we can do.

  • Hello

    PAPI lights have too much white light in Vulcan version, I did lots of ILS landing after the update, and I almost have never seen 2 white 2 red clearly on PAPI. Usually there is a huge white light with a tiny red in it.

    And the angle of PAPI is strange, it indicates I am too high even if I am on glide slope perfectly.

  • Strange shadow rendering with Vulkan (with or w/o AA)

    • Geometric shadows on pilots legs.
    • "Starburst" shadows around instruments.
    • Geometric shadows on medium distance mountains.

    All change position with pilot head position

    Appears in 2d and Rift

    GTX 1080TI with 398.36 driver

    nothing unusual in tm.log

    i7-6700K CPU @ 4.00GHz | ASUS Z170-A | 16Gb DDR4 | Samsung SSD 950 PRO NVME M.2 256GB | Samsung SSD 850 EVO 1TB | GeForce GTX 1080 Ti on GP102-A GPU | Oculus CV1 | Windows 10

  • Had the same issue , moving the shadow slider to High or insane fixed it for me .

  • A that issue, yeah yeah that's been there in the last version, no worries, I have it on the radar. Nothing I can do about it though, I'm afraid. The route is selecting the next leg a bit prematurely. I'll keep bugging the responsible programmer :D


    Please add the B737-500 to the list of planes with PRSS "premature route selection syndrome" when following a flight plan. This is most distracting and not just a small "dippy-do" that first appears to be a turn in the wrong direction but a full-blown "uh-oh" that magnifies the amount of bank needed to make the proper turn in the correct direction. :D:(=O



  • Hi,

    First, I start AFS2 (latest beta) in Steam, then select Steam VR mode when prompted.

    When I set graphic driver to Vulkan, my WMR Headset just displays the "grey room" I used to see before getting AFS2 home menu. The 6dof tracking remains ok, and everything on my 22-inches monitor seems to be ok, except for the yoke and the quadrant that are not responding (display, sound, keyboard and mouse ok).

    Reverting to OpenGL causes normal display in the headset. Restarting AFS2 (Steam VR mode) causes everything working back again.

    Hope this could help to debug.



    i5-6600K | 16GB DDR4 | 1TB Seagate SSHD | 1050Ti 4GB | Acer AH101 WMR HeadSet | Logitech Pro Flight Yoke System + Quadrant

    Windows 10 Pro 64-bit | nVidia drivers 398.36

  • Sometimes reloading the aircraft or restarting the simulator can fix these kinds of issues.

    Has the shadow been ok prior to the changes you made to the tmd file?

    If you made a mistake whilst editing the tmd file it's not really our fault... 8o

    Reboot and restart and the same problem appears.

    Not a tmd issue since it renders fine in OpenGL

    Switch over to Vulkan and weird shadows appear, back to OpenGl and it is fine!



    Problem occurs in low and medium Shadow quality

    High, ultra and insane are OK

    i7-6700K CPU @ 4.00GHz | ASUS Z170-A | 16Gb DDR4 | Samsung SSD 950 PRO NVME M.2 256GB | Samsung SSD 850 EVO 1TB | GeForce GTX 1080 Ti on GP102-A GPU | Oculus CV1 | Windows 10

    Edited 2 times, last by lenidcamper: cut paste error (July 5, 2018 at 7:34 PM).

  • Hi,

    I am experiencing screen freezes (sound continues) and subsequent crashes to desktop with the Vulkan Beta. My system: Windows 10, i7-6700HQ, Nvidia GeForce GTX 960M (newest drivers). System's performance with Aerofly in OpenGL and Vulkan mode is outstanding.

    Faulting application name: aerofly_fs_2.exe, version:, time stamp: 0x5b368400

    Faulting module name: nvoglv64.dll, version:, time stamp: 0x5b2fbb35

    Exception code: 0xc0000005

    Fault offset: 0x0000000000d065cd

    Faulting process id: 0x3e74

    Faulting application start time: 0x01d4129e7ee2bf09

    Faulting application path: C:\Steam\steamapps\common\Aerofly FS 2 Flight Simulator\bin64\aerofly_fs_2.exe

    Faulting module path: C:\WINDOWS\System32\DriverStore\FileRepository\nvaci.inf_amd64_cbe7e13da3856715\nvoglv64.dll

    Report Id: 3a71541c-fdc1-4652-8f4c-b65c0ebb994f

    Faulting package full name:

    Faulting package-relative application ID:

  • LJ45 does not capture LOC properly anymore, it swings left-right-left etc. Tested on ILS RWY 34 LSZH (Zurich). heading 335, ILS 110.75.

    Edit: I guess it may have to do with this from the change-log: - Added Advanced Autopilot predicts localizer overshoot and increases bank angle as needed.

    New beta release, it still does not work. It is impossible to capture LOC properly with LJ45.



    i7-14700KF @ 5.6 GHz, Geforce RTX 4090, 32MB RAM, 1TB SSD M.2, 1TB SSD M.2, 2TB SSD M.2, 32" Monitor 4K, Pimax Crystal

  • Not sure if this is a bug but the throttle quadrant on the Q400 doesn't seem to move smoothly with the VR hands once you get above idle.

    Also having issues with the reverse thrust using the VR hands - can't seem to get the reversers on.

    Edited once, last by deanl90 (July 5, 2018 at 6:35 PM).